Ver. 1.9 の次を Ver. 1.10 にしたときに起きる不具合例

jQuery のバージョン付けのことです。当然 数値でバージョンを比較するようなコードを書いていると 1.9 より 1.10 を古いバージョンとして判断してしまいます。

この Blog でも利用している WordPress プラグイン WP Lightbox 2 で次のような記述があって jQuery 1.1x を使用していると 1.7 未満と判断されて削除された live 関数を呼んでエラーになります。

if (parseFloat($().jquery) >= 1.7) {
return $(this).on("click", onClick);
} else {
// **reach to this line when using jQuery 1.1x**
return $(this).live("click", onClick); //deprecated since 1.7
}
view raw

gistfile1.txt

hosted with ❤ by GitHub

ただし、WordPress の Twenty Fourteen テンプレートなどでは jQuery 1.1x が使われているけど jquery-migrate.js も利用しているので、live 関数を使用できるみたい。

WordPress › Support » Compatibility issue

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク